sexta-feira, 22 de agosto de 2008

e-TextEditor no Linux! Agora vai!

Já dizia o velho ditado: "Quem não tem cão caça com gato!"

Foi o que eu fiz ao migrar definitivamente para o Linux.

Assim que comecei a configurar o linux para que eu pudesse continuar desenvolvendo em Rails me esbarrei na dificuldade de utilizar o gEdit, não por conta de naõ ter conseguido instalar os plugins (que por acaso instalei e deram todos certos), mas o detalhe foi que todos os atalhos e bundles que eu utilizava no e-TextEditor (sim, eu tenho a licença dele) simplesmente não tem a mesma combinação de teclas quando utilizados no gEdit.

Nessa situação eu tinha duas opções, ou aprender todos os novos atalhos e bundles do gEdit (o que não achei muito interessante) ou simplesmente voltar para o Windows já que não existe e-TextEditor para o Linux. Das duas opções escolhi uma terceira... :D rodar o e-TextEditor dentro do próprio Linux.

Para isso é possível tentar rodar ele via WINE, o que não me interessou muito por ver que algumas versões não funcionaram e também porque o e-TextEditor tem atualizações constantes. Sobrou apenas aproveitar o bom e velho VirtualBox e utilizá-lo.

Como a idéia é desenvolver no Linux não adiantaria nada rodar tudo dentro do VirtualBox, então o que eu precisava era apenas o editor, e foi isso que eu fiz. Compartilhei e fiz o mapeamento de da pasta do projeto no Linux, e através do VirtualBox abri meu projeto que está também no Linux, pronto! :D


Estou usando já a 1 semana e não tive nenhum problema.

vlw!

2 comentários:

Eduardo Mucelli disse...

Com Wine 1.1.9 e e-text 1.0.27 as coisas funcionam perfeitamente. Se você estiver usando Wine 1.0 e as coisas estiverem lentas (demais), configure o Wine para rodar como Windows XP, pois vem como default Windows ME (Horrível). Ou então atualize o Wine, que foi o que fiz.

Detalhe para um erro que ocorre aqui toda vez que abro um arquivo "Can not enumerate files in directory x:\y\z...

.::JACK::. disse...

Pois eh Eduardo...

É como eu falei, pode até funcionar, mas como sai muitas atualizações do e-TextEditor não sei se em alguma vai deixar de funcionar por acaso. Por exemplo, olhei agora no site deles e já estão na versão 1.0.30.

De qq forma vou fazer uns testes aqui. Vlw a dica! ;)